Writing lots of tests today and I found myself typing a lot of repetitive code just inserting test methods, so I created the ‘tm’ code snippet.
Of course, as I installed it, I realized that there was already a ‘testm’ code snippet to do almost exactly the same thing. I could/should have modified the original ‘testm’ to follow the naming convention for our tests. The moral of that story is look before you leap.
Will generate the following code snippet:
public void TestSuite_TestCondition_Assertion()